[lttng-dev] Error: Kernel create channel failed

Deneau, Tom tom.deneau at amd.com
Wed May 31 23:18:07 UTC 2017

Thanks, the new packages installed fine.
My original problem I solved by killing lttng-sessiond and restarting it...

-- Tom

-----Original Message-----
From: Jonathan Rajotte-Julien [mailto:jonathan.rajotte-julien at efficios.com] 
Sent: Wednesday, May 31, 2017 1:30 PM
To: Deneau, Tom <tom.deneau at amd.com>
Cc: lttng-dev at lists.lttng.org
Subject: Re: [lttng-dev] Error: Kernel create channel failed


On Tue, May 30, 2017 at 02:15:47PM +0000, Deneau, Tom wrote:
> I seem to have gotten my lttng into a state where kernel tracing does not work.
> I have tried uninstalling and reinstalling packages with no luck and also building from source.
> Any suggestions welcome.
> My distro is Ubuntu 16.04 but the kernel is 4.10.0-20-generic.

Are you using the hwe package? (linux-generic-hwe-16.04-edge)

> I have installed 2.9 using
> apt install linux-tools-generic dkmso

If using the hwe package you probably want to use the equivalent linux-tool-generic hwe package.

> apt-add-repository ppa:lttng/stable-2.9 apt-get update apt install -y 
> lttng-tools liblttng-ust-dev  liblttng-ust-agent-java  
> python3-lttngust lttng-modules-dkms wget 
> http://ftp.us.debian.org/debian/pool/main/l/lttng-modules/lttng-module
> s-dkms_2.9.1-1_all.deb dpkg -i lttng-modules-dkms_2.9.1-1_all.deb

I guess that this was to "fix" the installation error you had with installing lttng-modules-dkms. Reporting the installation issue would have been more straightforward.

The ppa packages were updated yesterday to fix the issue on installation.
Please update (apt update/upgrade) all lttng related packages. Also make sure to install babeltrace (apt install babeltrace) with updated libbabeltrace* dependencies.

> apt install -y babeltrace python3-babeltrace

> After lttng create test, I then try
> # lttng -vvv enable-channel k -k --num-subbuf 64 --subbuf-size 512k
> DEBUG1 - 08:27:54.415995 [13972/13972]: Channel subbuf num set to 64 
> (in cmd_enable_channels() at commands/enable_channels.c:420)
> DEBUG1 - 08:27:54.416045 [13972/13972]: Channel subbuf size set to 
> 524288 (in cmd_enable_channels() at commands/enable_channels.c:384)
> DEBUG2 - 08:27:54.416080 [13972/13972]: Config file path found: /root 
> (in _get_session_name() at utils.c:63)
> DEBUG1 - 08:27:54.416087 [13972/13972]: Session name found: test (in 
> _get_session_name() at utils.c:64)
> DEBUG1 - 08:27:54.416099 [13972/13972]: Enabling channel k (in 
> enable_channel() at commands/enable_channels.c:225)
> DEBUG1 - 08:27:54.416129 [13972/13972]: LSM cmd type : 5 (in 
> send_session_msg() at lttng-ctl.c:135)
> Error: Channel k: Kernel create channel failed (session test)
> Error: Command error
> DEBUG1 - 08:27:54.416479 [13972/13972]: Clean exit (in clean_exit() at 
> lttng.c:149)

I tested ppa stable 2.9 installation on both vanilla 16.04 and 16.04 with the 4.10.0-21-generic kernel provided by linux-generic-hwe-16.04-edge. Both works with the updated ppa (update performed by Michael Jeanson).

Only had a minor dependency issue with babeltrace but it was fixed by reinstalling it.


> _______________________________________________
> lttng-dev mailing list
> lttng-dev at lists.lttng.org
> https://lists.lttng.org/cgi-bin/mailman/listinfo/lttng-dev

Jonathan Rajotte-Julien

More information about the lttng-dev mailing list