[lttng-dev] CTF model.emf.uri precision
yannick.brosseau at gmail.com
Tue Sep 25 14:20:54 EDT 2012
On 2012-09-24 22:25, Mathieu Desnoyers wrote:
> * Matthew Khouzam (matthew.khouzam at ericsson.com) wrote:
>> Hi tracing paladins,
>> I was going over the most recent CTF specs. I am curious, at the line:
>> 1176 "model.emf.uri = "string";" this looks like a reference to
>> something from eclipse modeling framework.
>> Is this part of the CTF specification? Shouldn't this be called
>> model.uri or model_uri to respect the naming convention?
> if we only call it model.uri, and come up with other model URIs that we
> want to encode in the future (not emf-related), then we would be
> stucked, wouldn't we ?
> What is the benefit of removing the "emf" part ?
I don't see the benifit of having the "emf". From what I see, its just
an URI, so there is no real link to that an EMF. We could put any kind
of model there?!?.
Also, why not just having a generic way to add a constant string to the
More information about the lttng-dev