[lttng-dev] CTF model.emf.uri precision

Matthew Khouzam matthew.khouzam at ericsson.com
Tue Sep 25 14:39:24 EDT 2012

A fun solution could be a map of key values where you can put everything:
eventNameherething :={
{"loglevel" , "1"},
{"model.emf.uri" , "www.thingy"},
{"drink.coca.cola.(tm)" , "pepsi"},
On 12-09-25 02:20 PM, Yannick Brosseau wrote:
> On 2012-09-24 22:25, Mathieu Desnoyers wrote:
>> * Matthew Khouzam (matthew.khouzam at ericsson.com) wrote:
>>> Hi tracing paladins,
>>> I was going over the most recent CTF specs. I am curious, at the line:
>>> 1176   "model.emf.uri = "string";" this looks like a reference to
>>> something from eclipse modeling framework.
>>> http://download.eclipse.org/modeling/emf/emf/javadoc/2.7.0/org/eclipse/emf/common/util/URI.html
>>> Is this part of the CTF specification? Shouldn't this be called
>>> model.uri or model_uri to respect the naming convention?
>> if we only call it model.uri, and come up with other model URIs that we
>> want to encode in the future (not emf-related), then we would be
>> stucked, wouldn't we ?
>> What is the benefit of removing the "emf" part ?
> I don't see the benifit of having the "emf". From what I see, its just
> an URI, so there is no real link to that an EMF. We could put any kind
> of model there?!?.
> Also, why not just having a generic way to add a constant string to the
> event?
> Yannick
> _______________________________________________
> lttng-dev mailing list
> lttng-dev at lists.lttng.org
> http://lists.lttng.org/cgi-bin/mailman/listinfo/lttng-dev

More information about the lttng-dev mailing list