[ltt-dev] LTTng kernel patches not patching successfully

Mathieu Desnoyers compudj at krystal.dyndns.org
Fri Jul 17 09:43:59 EDT 2009

* Ajit R (ajitrzid at yahoo.com) wrote:
> Hello
>   I want to try out LTT on my x86 32 bit machine before I move to an ARM target. The tried the following steps
> 1) Download kernel from kernel.org. Version linux-2.6.23.tar.bz2
> 2) Patched with the "mm" patch - 2.6.23-mm1.bz2

I would recommend staying with "stable" kernels rather than experimental
-mm kernels when possible.

> 3) Tried patching "patch-2.6.23-mm1-lttng-0.10-pre14.tar.bz2" to the mm1 kernel tree. This fails with multiple rejects.
> 4) Tried patching "patch-2.6.23-mm1-lttng-0.10-pre7.tar.bz2". This also fails with multiple rejects.
> 5) Patched the vanilla 2.6.23 kernel to 2.6.30.
> 6) Also tried : "patch-2.6.30-lttng-0.148.tar.bz2" 
>     This fails too with multiple rejects.
> Downloaded patches from "http://ltt.polymtl.ca/files/lttng/".
> Is this normal or am I doing something wrong?

Make sure to review the LTTng manual on the lttng.org website,

The 2.6.30 patch should work. Can you paste the whole sequence of:

and the commands you use to apply the patchset, with the error you get?



> Ajit
> _______________________________________________
> ltt-dev mailing list
> ltt-dev at lists.casi.polymtl.ca
> http://lists.casi.polymtl.ca/cgi-bin/mailman/listinfo/ltt-dev

Mathieu Desnoyers
OpenPGP key fingerprint: 8CD5 52C3 8E3C 4140 715F  BA06 3F25 A8FE 3BAE 9A68

More information about the lttng-dev mailing list