[lttng-dev] LTTng Support for Mount Namespace

Michael Jeanson mjeanson at efficios.com
Tue Jan 12 13:51:23 EST 2021

On 2021-01-12 12 h 29, Mohammad Kavousi wrote:
> Thanks again for your reply,
> To be specific, I did exactly this:
> - Install linux source code, then copy the mentioned file to the folder 
> using: cp 
> /usr/src/linux-headers-5.4.0-59/fs/mount.h /lib/modules/$(uname -r)/build

The path to the header has to stay the same, so you would need to copy 
it to '/lib/modules/$(uname -r)/build/fs'.

The rest of the steps seem fine.

One thing you can do if it still doesn't work, is modify 'Makefile' and 
'Kbuild.common' in the lttng-modules source directory and remove the 
conditions on 'mnt_ns_dep'. That would make the build fail when 
'fs/mount.h' isn't found and may help you find the cause.

> - Run sudo dkms autoinstall (I also did reboot)
> - Create the session and attempt to add the context
> However, I'm getting the same error.

More information about the lttng-dev mailing list