[lttng-dev] [EXTERNAL] Re: lttng 2.12 install

Weber, John jweber1 at ball.com
Tue Nov 24 17:01:23 EST 2020

Ok, so still same situation however it appears that the make program is able to use the devtoolset gcc but I still get the error. My work environment is classified however, this system has already been updated. If I try to up or down with versioning I am sure to have a dependency nightmare. I'm not sure what to do at this point. I guess I'm kind of confused over this whole issue of installing your software. I'm running centos 7.8 which is recent. Why isn’t my current version of gcc good enough? Is lttng 2.12 so new it only works on linux newer than 7.8??? sorry just not sure why this problem even exists at this point. Does 2.12 only work on linux version 8+? Would an older version of lttng be even work it? I mean the software that I install for our environment is as new as possible. I support a team of aerospace software developers. Maybe this just isn’t an option and maybe we should look at something else. I also have version 2.4 but that seems to be to old in comparison to the other software we use. Thoughts?

John Weber
Ball Aerospace
ITS ND System Administrator 
10 Longs Peak Dr., Broomfield, CO 80021
C: 303-807-3608   P: 303-234-2103
E: jweber1 at ball.com



-----Original Message-----
From: Michael Jeanson <mjeanson at efficios.com> 
Sent: Tuesday, November 24, 2020 2:41 PM
To: Weber, John <jweber1 at ball.com>; 'Jonathan Rajotte-Julien' <jonathan.rajotte-julien at efficios.com>
Cc: 'lttng-dev at lists.lttng.org' <lttng-dev at lists.lttng.org>
Subject: Re: [lttng-dev] [EXTERNAL] Re: lttng 2.12 install

On 2020-11-24 16 h 02, Weber, John via lttng-dev wrote:
> Ok, it I get what you're saying then I am modifying make on the 
> command line while running make? Still the same problem. I don't think 
> it is using the gcc I am specifying as it continues to look in: 
> /usr/src/kernels/3.10.0-1127.19.1.el7.x86_64/
> And I suspect it is still seeing the OS version of gcc (4.8.5) instead of the 6.3.1 provided by devtoolset-6.
> Do you have some pixy dust??

Running this will get you verbose output while building which should help you determine which compiler and other tools are used :

   make CC="/opt/rh/devtoolset-6/root/bin/gcc" V=1

This message and any enclosures are intended only for the addressee.  Please 
notify the sender by email if you are not the intended recipient.  If you are 
not the intended recipient, you may not use, copy, disclose, or distribute this 
message or its contents or enclosures to any other person and any such actions 
may be unlawful.  Ball reserves the right to monitor and review all messages 
and enclosures sent to or from this email address.

More information about the lttng-dev mailing list