[lttng-dev] Installing LTTNG on beaglebone black or rasberry pi

Nwafor, Ebelechukwu ebelechukwu.nwafor at bison.howard.edu
Thu Nov 17 21:24:29 UTC 2016

Hi Jonathan. Thank you for your response.

On the beaglebone black, i tried building lttng-tools, lttng-modules-dkms
and lttng-ust-dev from source v2.8.1 by following the documentation.
lttng-modules-dkms runs fine but the module does not show up on the list of
running modules when i issue an lsmod command. Also, i run into errors
while trying to build and compile lttng-tools. Beaglebone black runs on
debian. Linux beaglebone 3.8.13-bone70 #1 SMP Fri Jan 23 02:15:42 UTC 2015
armv7l GNU/Linux

On the raspberry pi, I use the commands, apt-get install lttng-modules-dkms
lttng-tools lttng-ust-dev. Everything seems to work fine with the exception
of lttng-modules-dkms which does not show up on the list on running
modules. Also, every time i try to view available kernel events, it comes
up with an error saying unable to list kernel events: kernel tracer not
available. The LTTNG version installed using apt-get is 2.7.1. I am running
ubuntu mate OS. Below are the output while installing lttng-modules-dkms

root at ebele-desktop:~# apt-get install lttng-modules-dkms
Reading package lists... Done
Building dependency tree
Reading state information... Done
lttng-modules-dkms is already the newest version (2.7.1-1).
0 upgraded, 0 newly installed, 0 to remove and 14 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Setting up linux-headers-4.4.0-22 (4.4.0-22.40) ...
Setting up lttng-modules-dkms (2.7.1-1) ...
Loading new lttng-modules-2.7.1 DKMS files...
First Installation: checking all kernels...
dpkg: warning: version '*-*' has bad syntax: version number does not start
with digit
It is likely that 4.4.30-v7+ belongs to a chroot's host
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.
root at ebele-desktop:~#

On Thu, Nov 17, 2016 at 3:00 PM, Jonathan Rajotte <
jonathan.r.julien at gmail.com> wrote:

> Hi,
> Could you be a bit more precise regarding which part of the documentation
> does not work ?
> How did you install it ? Distribution packages ? From sources ? Cross
> compiled ?
> What is your setup ? Raspian for the Pi ? Custom kernel image ?
> Cheers
> On Thu, Nov 17, 2016 at 2:54 PM, Nwafor, Ebelechukwu <
> ebelechukwu.nwafor at bison.howard.edu> wrote:
>> Hello.
>> I am trying to install LTTNG tracing tool on raspberry pi and beaglebone
>> black board.The official LTTNG documentation does not work on these
>> devices. Does anyone know of any tutorial that can help me accomplish this?
>> Thanks.
>> --
>> Ebelechukwu Nwafor,
>> Graduate Student,
>> Howard University.
>> _______________________________________________
>> lttng-dev mailing list
>> lttng-dev at lists.lttng.org
>> https://lists.lttng.org/cgi-bin/mailman/listinfo/lttng-dev
> --
> Jonathan Rajotte Julien

Ebelechukwu Nwafor,
Graduate Student,
Howard University.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.lttng.org/pipermail/lttng-dev/attachments/20161117/57ee1354/attachment-0001.html>

More information about the lttng-dev mailing list