[lttng-dev] Errors compiling converted tp file

Alexandre Montplaisir alexmonthy at voxpopuli.im
Fri Dec 12 16:49:30 EST 2014


There is indeed something weird with the lttng-modules package on 12.04. 
But if you are only doing userspace tracing, then that part should not 
matter, all you need is "lttng-tools" and "liblttng-ust-dev".

You also seem to have lots of older package versions installed. This can 
sometimes create problems, as an application can link against one 
version of the UST library, but the tracer control will use another, 
which will result in no tracepoints being taken.

To be safe you might want to remove (with "apt-get purge") everything 
that is listed there, and only reinstall those you need from the PPA. 
This should avoid duplicate versions of liburcu and liblttng-ust*.
Also make sure you have no lingering libraries in /usr/local. This is 
another very common problem!

Let us know if it still doesn't work.


On 12/12/2014 08:58 AM, Jérémie Galarneau wrote:
> On Fri, Dec 12, 2014 at 5:59 AM, Yan Grange <ygrange at gmail.com> wrote:
>> Hi,
>> Let me start by thanking you for all the support you give (it is impressingly fast).
>> So if I look in the repo, with the ppa installed, I can't find liburcu:
>> $ cat /etc/apt/sources.list.d/lttng-ppa-precise.list
>> deb http://ppa.launchpad.net/lttng/ppa/ubuntu precise main
>> deb-src http://ppa.launchpad.net/lttng/ppa/ubuntu precise main
>> (I have asked my admin to do an apt-get update)
>> $ apt-cache search lttng
>> lttng-modules-dkms - Linux Trace Toolkit (LTTng) kernel modules (DKMS)
>> lttng-tools - LTTng control and utility programs
>> liblttng-ust0 - LTTng 2.0 Userspace Tracer (libraries)
>> liblttng-ust-dev - LTTng 2.0 Userspace Tracer (development files)
>> liblttng-ctl-dev - LTTng control and utility library (development files)
>> liblttng-ctl0 - LTTng control and utility library
>> liblttng-ust-java-jni - LTTng 2.0 Userspace Tracer (JNI interface)
>> liblttng-ust-java - LTTng 2.0 Userspace Tracer (Java support library)
>> python-lttng - Python bindings for LTTng
>> liblttng-ust-ctl2 - LTTng 2.0 Userspace Tracer (trace control library)
>> $ apt-cache search liburcu
>> liburcu-dev - a userspace RCU (read-copy-update) library - development files
>> liburcu1 - a userspace RCU (read-copy-update) library
>> liburcu2 - a userspace RCU (read-copy-update) library
>> So it looks like my aptitude is not aware of a package called liburcu without a postfix… Even if I'd purge and reinstall (which seems like a very good idea) I don't see if I can access the right library this way.
> The packaging situation on Ubuntu 12.04 is a little confusing...
> As far as I can tell, you have
> liburcu (the one available in the official Ubuntu 12.04 repos, v0.6.7)
> liburcu1 (v0.7.x)
> liburcu2 (v0.8.x)
> The LTTng version on the PPA (v2.5.x) depends on the 0.8 liburcu.
> Therefore, liburcu2 is the one you want to install.
> Looking at the dependencies, it seems that installing lttng-tools and
> lttng-modules-dkms (from the PPA) should have you covered and install
> everything you need.
> CC-ing Alexandre Montplaisir who maintains most of these packages.
> Regards,
> Jérémie
>> Cheers
>> Yan Grange
>> On 11 dec. 2014, at 18:08, Jérémie Galarneau <jeremie.galarneau at efficios.com> wrote:
>>> On Thu, Dec 11, 2014 at 8:56 AM, Yan Grange <ygrange at gmail.com> wrote:
>>>> Hi,
>>>> I can't really make out
>>>>>> However it actually works to create a header file from a tp file and compile (and run) the code. However I now get in trouble when executing:
>>>>>> $ lttng list --userspace
>>>>>> Error: Unable to list UST events: Undefined command
>>>>>> Error: Command error
>>>>>> So I guess something still went somewhat wrong but I can't really see what.
>>>>>> Yan Grange
>>>>>   In order to trace user-space, you must install, in sequence, the following packages: userspace-rcu, lttng-ust, lttng-tools.  Was this done?
>>>> I tried to install the right packages but there don't seem to be packages named like that in either the ubuntu repository or the ppa provided by you.
>>>> I have the following packages installed:
>>>> lttng-tools
>>>> liblttng-ust0
>>>> liblttng-ust-dev
>>>> liblttng-ust-ctl2
>>>> liblttng-ctl0
>>>> liburcu-dev
>>>> liburcu2
>>> Some of these packages appear to be conflicting. You'd be better off
>>> removing them all and starting fresh from the PPA.
>>> Jérémie
>>>> With all this installed, I still don't get it to work.
>>>> Cheers
>>>> Yan Grange
>>>> _______________________________________________
>>>> lttng-dev mailing list
>>>> lttng-dev at lists.lttng.org
>>>> http://lists.lttng.org/cgi-bin/mailman/listinfo/lttng-dev
>>> --
>>> Jérémie Galarneau
>>> EfficiOS Inc.
>>> http://www.efficios.com

More information about the lttng-dev mailing list