[lttng-dev] Trace files not getting generated

David Goulet dgoulet at efficios.com
Mon Sep 10 11:12:29 EDT 2012

Hash: SHA512

Hi Carlos,

One thing you could do is to make sure the lttng-consumerd is
installed and accessible by the session daemon. You'll see that in the
lttng-sessiond -vvv logs during the session creation.

It would help us a lot if you could send us the full session daemon
debug output using "-vvv --verbose-consumer".

Could you use the LTTng bug tracker for that so we have a reference in
the future and help us track the issue overtime.


Thanks a lot!

Carlos de Sa:
> Hi,
> I've been trying to get kernel tracing working on a TI AM355X EVM 
> using the standard arago 05.05 toolchain, kernel & ti-sdk
> filesystem; but seem to have some buffer issues. Any help on this
> would be much appreciated.
> After starting a trace session I ran a few programs - the graphics 
> package apps and standard demo apps. After stopping all seems to
> be fine but when I destroy the session it generates a warning. And
> the session dir (session2-20120727-122650) is empty as can be seen
> below -
> root at am335x-evm:~/lttng-traces# arm-arago-linux-gnueabi-lttng
> enable-event sched _switch,sched_wakeup -k kernel event
> sched_switch created in channel channel0 kernel event sched_wakeup
> created in channel channel0 root at am335x-evm:~/lttng-traces#
> arm-arago-linux-gnueabi-lttng add-context -k -e sched_switch -t
> pid kernel context pid added to event sched_switch 
> root at am335x-evm:~/lttng-traces# arm-arago-linux-gnueabi-lttng
> start Tracing started for session session2 
> root at am335x-evm:~/lttng-traces# arm-arago-linux-gnueabi-lttng stop 
> Tracing stopped for session session2 
> root at am335x-evm:~/lttng-traces# ls session1-20120727-122409
> session2-20120727-122650 root at am335x-evm:~/lttng-traces# ls
> session2-20120727-122650/kernel/ root at am335x-evm:~/lttng-traces# ls
> session2-20120727-122650/kernel/ root at am335x-evm:~/lttng-traces#
> arm-arago-linux-gnueabi-lttng destroy [ 1049.263275] ring buffer
> relay-discard, cpu 0: records were lost. Caused by: [ 1049.263275]
> [ 21949 buffer full, 0 nest buffer wrap-around, 0 event too big ] 
> Session session2 destroyed at /home/root root at am335x-evm:~# ls
> lttng-traces/session2-20120727-122650/kernel/ root at am335x-evm:~# ls
> lttng-traces/session2-20120727-122650/
> Any idea whats going wrong? Fyi I also have debugfs enabled and 
> mounted. And sessiond when run with -vvv option does not show any 
> errors.
> Previously when enabling all traces (enable-event -a -k) I got the 
> error at "LTTng: Failure to write metadata to buffers (timeout)"
> when starting. I thought this may have been a kernel buffer issue
> due to enabling all possible events. But the above log does not
> show the same issue so thought this case of only a few events
> should have worked.
> Regards, Carlos
> _______________________________________________ lttng-dev mailing
> list lttng-dev at lists.lttng.org 
> http://lists.lttng.org/cgi-bin/mailman/listinfo/lttng-dev


More information about the lttng-dev mailing list