[lttng-dev] Trace files not getting generated

Carlos de Sa desa.carlos at gmail.com
Mon Sep 10 02:42:32 EDT 2012


I've been trying to get kernel tracing working on a TI AM355X EVM
using the standard arago 05.05 toolchain, kernel & ti-sdk filesystem;
but seem to have some buffer issues. Any help on this would be much

After starting a trace session I ran a few programs - the graphics
package apps and standard demo apps. After stopping all seems to be
fine but when I destroy the session it generates a warning. And the
session dir (session2-20120727-122650) is empty as can be seen below -

root at am335x-evm:~/lttng-traces# arm-arago-linux-gnueabi-lttng enable-event sched
_switch,sched_wakeup -k
kernel event sched_switch created in channel channel0
kernel event sched_wakeup created in channel channel0
root at am335x-evm:~/lttng-traces# arm-arago-linux-gnueabi-lttng add-context -k -e
sched_switch -t pid
kernel context pid added to event sched_switch
root at am335x-evm:~/lttng-traces# arm-arago-linux-gnueabi-lttng start
Tracing started for session session2
root at am335x-evm:~/lttng-traces# arm-arago-linux-gnueabi-lttng stop
Tracing stopped for session session2
root at am335x-evm:~/lttng-traces# ls
session1-20120727-122409  session2-20120727-122650
root at am335x-evm:~/lttng-traces# ls session2-20120727-122650/kernel/
root at am335x-evm:~/lttng-traces# ls session2-20120727-122650/kernel/
root at am335x-evm:~/lttng-traces# arm-arago-linux-gnueabi-lttng destroy
[ 1049.263275] ring buffer relay-discard, cpu 0: records were lost. Caused by:
[ 1049.263275]   [ 21949 buffer full, 0 nest buffer wrap-around, 0
event too big ]
Session session2 destroyed at /home/root
root at am335x-evm:~# ls lttng-traces/session2-20120727-122650/kernel/
root at am335x-evm:~# ls lttng-traces/session2-20120727-122650/

Any idea whats going wrong? Fyi I also have debugfs enabled and
mounted. And sessiond when run with -vvv option does not show any

Previously when enabling all traces (enable-event -a -k) I got the
error at "LTTng: Failure to write metadata to buffers (timeout)" when
starting. I thought this may have been a kernel buffer issue due to
enabling all possible events. But the above log does not show the same
issue so thought this case of only a few events should have worked.


More information about the lttng-dev mailing list