[lttng-dev] urcu commit a767fd requires autoconf >= 2.64.

John Steele Scott toojays at toojays.net
Wed Jun 13 09:11:57 EDT 2012

On 13/06/12 17:40, Mathieu Desnoyers wrote:
> * John Steele Scott (toojays at toojays.net) wrote:
>> http://lists.lttng.org/pipermail/lttng-dev/2012-May/017927.html
>> I tried to build the latest urcu (git master e51500) on a Centos 6.2 box, and got:
>> jscott at dxi0-62:~/src/userspace-rcu$ make -j4
>> CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/sh /users/jscott/src/userspace-rcu/config/missing --run aclocal-1.11 -I config
>> CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/sh /users/jscott/src/userspace-rcu/config/missing --run autoconf
>>  cd . && /bin/sh /users/jscott/src/userspace-rcu/config/missing --run automake-1.11 --foreign
>> configure:4010: error: possibly undefined macro: m4_ifnblank
>>       If this token and others are legitimate, please use m4_pattern_allow.
>>       See the Autoconf documentation.
>> make: *** [configure] Error 1
>> make: *** Waiting for unfinished jobs....
>> Some digging showed that the macro m4_ifnblank requires autoconf 2.64. Centos 6.2 has autoconf 2.63. :(
>> I just worked around it by reverting commit a767fd locally, then I can build fine.
> Thanks for pointing this out! Can you try the following patch and let me
> know if it fixes your issue ?


Thanks for your quick response. Unfortunately, with that patch, ./configure fails like:

checking for thread local storage (TLS) class... __thread
./configure: line 4029: syntax error near unexpected token `fi'
./configure: line 4029: `fi'

The section of configure which it's complaining about looks like:

 if test "$ac_cv_tls" != "none"; then

     cat >>confdefs.h <<_ACEOF                                                                                                                                                                                    
#define TLS $ac_cv_tls                                                                                                                                                                                            

     cat >>confdefs.h <<_ACEOF                                                                                                                                                                                    
#define CONFIG_RCU_TLS $ac_cv_tls                                                                                                                                                                                 



It seems it doesn't like the empty else..fi clause. If I put a command in there ("true", "echo", whatever), configure completes and I can build successfully.



More information about the lttng-dev mailing list