[lttng-dev] urcu commit a767fd requires autoconf >= 2.64.

John Steele Scott toojays at toojays.net
Wed Jun 13 03:04:42 EDT 2012


I tried to build the latest urcu (git master e51500) on a Centos 6.2 box, and got:

jscott at dxi0-62:~/src/userspace-rcu$ make -j4
CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/sh /users/jscott/src/userspace-rcu/config/missing --run aclocal-1.11 -I config
CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/sh /users/jscott/src/userspace-rcu/config/missing --run autoconf
 cd . && /bin/sh /users/jscott/src/userspace-rcu/config/missing --run automake-1.11 --foreign
configure:4010: error: possibly undefined macro: m4_ifnblank
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
make: *** [configure] Error 1
make: *** Waiting for unfinished jobs....

Some digging showed that the macro m4_ifnblank requires autoconf 2.64. Centos 6.2 has autoconf 2.63. :(

I just worked around it by reverting commit a767fd locally, then I can build fine.



More information about the lttng-dev mailing list