[ltt-dev] Trouble tracing my application for PowerPC board

Mathieu Desnoyers compudj at krystal.dyndns.org
Mon Feb 14 23:34:46 EST 2011

* Srivatsan Vijayaraghavan (srivatsanvijayaraghavan at yahoo.com) wrote:
> I used ltib to cross compile and build liburcu and libust on my target board (for powerpc). Everything went smooth with few glitches which were sorted out, but when I tried to trace my application by invoking it from usttrace (usttrace ./testust), I wasn't able to get beyond this message
>     /root/.usttracers/...../ust-consumerd.log - No such file or directory
> I tried recording the trace manually when ust-consumerd failed in epoll_create().
> So I built the kernel with CONFIG_EPOLL support, but that did not help. I still get the same /root/.usttracers/..../ust-consumerd.log - No such file or directory 
> ---testust.cpp---
> #include <ust.marker.h>
> int main(..)
> {
>    trace_mark(main,myevent,"%d", getpid());
> }

which user ID are your running your application as ?

What's the value of your $HOME ?

It looks like ust is unable to create the directories/files needed to
write the log file. It looks like an access right problem


> Thanks,
> Srivatsan V
> ____________________________________________________________________________________
> Food fight? Enjoy some healthy debate 
> in the Yahoo! Answers Food & Drink Q&A.
> http://answers.yahoo.com/dir/?link=list&sid=396545367
> _______________________________________________
> ltt-dev mailing list
> ltt-dev at lists.casi.polymtl.ca
> http://lists.casi.polymtl.ca/cgi-bin/mailman/listinfo/ltt-dev

Mathieu Desnoyers
Operating System Efficiency R&D Consultant
EfficiOS Inc.

More information about the lttng-dev mailing list