[ltt-dev] Trouble tracing my application for PowerPC board

Srivatsan Vijayaraghavan srivatsanvijayaraghavan at yahoo.com
Mon Feb 14 23:19:38 EST 2011

I used ltib to cross compile and build liburcu and libust on my target board (for powerpc). Everything went smooth with few glitches which were sorted out, but when I tried to trace my application by invoking it from usttrace (usttrace ./testust), I wasn't able to get beyond this message
    /root/.usttracers/...../ust-consumerd.log - No such file or directory

I tried recording the trace manually when ust-consumerd failed in epoll_create().
So I built the kernel with CONFIG_EPOLL support, but that did not help. I still get the same /root/.usttracers/..../ust-consumerd.log - No such file or directory 

#include <ust.marker.h>
int main(..)
   trace_mark(main,myevent,"%d", getpid());

Srivatsan V

Food fight? Enjoy some healthy debate 
in the Yahoo! Answers Food & Drink Q&A.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.casi.polymtl.ca/pipermail/lttng-dev/attachments/20110214/f1a518ff/attachment-0003.htm>

More information about the lttng-dev mailing list