[lttng-dev] problem running/installing lttng on ubuntu 16.04

Noam Cohen noam at lifeonair.com
Wed Aug 17 10:25:48 UTC 2016

I installed lttng on my ubuntu, and tried the "getting Started".

I ran the helloWorld, and then
$ lttng list --userspace
Error: Unable to list UST events: No session daemon is available
Error: Command error

Waited a minute and retried, and now the output was as expected.
$ lttng list --userspace
UST events:

PID: 17386 - Name: ./hello
      lttng_ust_tracelog:TRACE_DEBUG (loglevel: TRACE_DEBUG (14)) (type:
      < SNIP >
      hello_world:my_first_tracepoint (loglevel: TRACE_DEBUG_LINE (13))
(type: tracepoint)

**Is it normal behavior?*

$ lttng create
Session auto-20160817-132123 created.
Traces will be written in /home/noam/lttng-traces/auto-20160817-132123
noam at noam-nuc:~/tmp/lttng$ lttng enable-event --userspace
Error: Event hello_world:my_first_tracepoint: UST create channel failed
(channel channel0, session auto-20160817-132123)

How do I solve it?
system properties:

noam at noam-nuc:~$ ps -ef | grep lttng
noam     17410 17398  0 13:18 pts/3    00:00:00 lttng-sessiond -vvv
noam     17411 17410  0 13:18 pts/3    00:00:00 lttng-runas    -vvv
noam     17442 17410  0 13:21 pts/3    00:00:00 lttng-consumerd  -u
--consumerd-cmd-sock /home/noam/.lttng/ustconsumerd64/command
--consumerd-err-sock /home/noam/.lttng/ustconsumerd64/error --group tracing
noam     17444 17442  0 13:21 pts/3    00:00:00 lttng-runas      -u
--consumerd-cmd-sock /home/noam/.lttng/ustconsumerd64/command
--consumerd-err-sock /home/noam/.lttng/ustconsumerd64/error --group tracing
noam     17480 17467  0 13:22 pts/7    00:00:00 grep --color=auto lttng
noam at noam-nuc:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.1 LTS
Release: 16.04
Codename: xenial

Installed lttng using:
sudo apt-get install lttng-tools lttng-modules-dkms liblttng-ust-dev

$ lttng --version
lttng (LTTng Trace Control) 2.7.1 - Herbe à Détourne
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.lttng.org/pipermail/lttng-dev/attachments/20160817/f3339dec/attachment.html>

More information about the lttng-dev mailing list