[lttng-dev] [RFC lttng-ust] Renaming llttng_ust_statedump:soinfo
mathieu.desnoyers at efficios.com
Fri Apr 15 19:55:57 UTC 2016
----- On Apr 15, 2016, at 3:43 PM, Antoine Busque abusque at efficios.com wrote:
> I'd like to suggest renaming the lttng_ust_statedump:soinfo event.
> Indeed, the current name feels somewhat misleading given that it
> applies not only to loaded shared objects, but also to executables,
> whether they are position-independent executables (PIE) or not.
> I would propose changing the name to "bin_info", as I feel this would
> encompass both executables and shared objects. The event's field
> "sopath" should also be renamed to simply "path" for the same
> I think it's important to keep to a minimum such name changes, but now
> seems like a reasonable time to do it before it becomes widely used
> for analyses in babeltrace and Trace Compass.
Indeed, those new field names would be cleaner. AFAIK, this would be a good
timing to do this change before Trace Compass, Babeltrace and LTTng Analyses
start to really use these fields.
If there are other viewers that really deeply care about the name of
those fields, speak up now.
> Best regards,
> Antoine Busque.
More information about the lttng-dev