[lttng-dev] LTTng-modules install failed on a Parallella

Thomas Bertauld thomas.bertauld at gmail.com
Wed May 20 16:31:06 EDT 2015

Hi !

I recently began to work on a Parallella board and I wanted to try tracing
the ARM processor with LTTng before doing ant work with the Epiphany chip

Nevertheless, i'm stuck with an error anytime i try to install the
lttng-modules. I've tried installing it from the official repositories and
from the PPA but none worked.

For now i only tried with the headless version of Ubuntu 14.04 (
http://www.parallella.org/create-sdcard/) for the Zynq-7010 (the processor
itself is a ARM Cortex A9).

The kernel version is 3.14.12, as seen in the error message below

parallella at parallella:~$ sudo apt-get install lttng-modules-dkms
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
The following NEW packages will be installed:
  dkms lttng-modules-dkms
0 upgraded, 2 newly installed, 0 to remove and 1 not upgraded.
Need to get 286 kB of archives.
After this operation, 2816 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://ports.ubuntu.com/ trusty-updates/main dkms all [64.6 kB]
Get:2 http://ports.ubuntu.com/ trusty-updates/universe lttng-modules-dkms
all 2.4.0-1ubuntu1.1 [221 kB]
Fetched 286 kB in 0s (356 kB/s)
Selecting previously unselected package dkms.
(Reading database ... 39070 files and directories currently installed.)
Preparing to unpack .../dkms_2.2.0.3-1.1ubuntu5.14.04_all.deb ...
Unpacking dkms ( ...
Selecting previously unselected package lttng-modules-dkms.
Preparing to unpack .../lttng-modules-dkms_2.4.0-1ubuntu1.1_all.deb ...
Unpacking lttng-modules-dkms (2.4.0-1ubuntu1.1) ...
Processing triggers for man-db ( ...
Setting up dkms ( ...
Setting up lttng-modules-dkms (2.4.0-1ubuntu1.1) ...

*Loading new lttng-modules-2.4.0 DKMS files...First Installation: checking
all kernels...dpkg: warning: version '*-*' has bad syntax: version number
does not start with digitIt is likely that
3.14.12-parallella-xilinx-g40a90c3 belongs to a chroot's host*

And at this point the installation just stop and i'm back with the prompt.

Since i'm quite new in the LTTng universe i don't know what to do. I made
some researches on the subject but there was nothing for the Parallella. I
only found an answer for a similar problem suggesting to install the kernel
causing this trouble in the chroot environment, but i'm not quite sure how
to do this properly.

Thanks in advance !

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lttng.org/pipermail/lttng-dev/attachments/20150520/34fa8635/attachment.html>

More information about the lttng-dev mailing list