[lttng-dev] Can't get any event output from the demo exe [solved]

Alexandre Montplaisir alexmonthy at voxpopuli.im
Sun Mar 29 18:01:23 EDT 2015

On 15-03-27 07:00 AM, Wolfgang Rostek wrote:
> Hi Mathieu,
> weeks ago I did a different approach installing packages.
> That one I can't recap.

What I suspect happened here is that you installed some of the packages 
from source using "make install", which copies the libraries in 
/usr/local/lib/* .

*Then* you installed the packaged versions, which go in /usr/lib/*. But 
the tricky part is that on Ubuntu and many other (most?) distros, the 
ld.so.conf is configured to look in /usr/local/lib first for shared 
libraries. If it finds a useable one, it loads that one and stops there.

In such a case, /usr/bin/lttng, installed from packages, would end up 
using /usr/local/lib/liblttng-ust*.so, and so on. If both are not of the 
exact same version, it can cause obscure problems like the one you had.

This is a very common source of problems in fact. I don't know of any 
easy fix unfortunately, short of teaching people about library mangement 
;) or bumping the soname of lttng-tools and UST's shared libraries every 
release, to make sure non-compatible libraries are not loaded.


> Today I tried this one and simply started to get rid of existing things.
> I would see this as a beginners confusion and not worth
> to spend time here.
> I'm quite happy to see the nice LTTng output ;)
> Wolfgang R.
>> Gesendet: Freitag, 27. März 2015 um 14:52 Uhr
>> Von: "Mathieu Desnoyers" <mathieu.desnoyers at efficios.com>
>> An: "Wolfgang Rostek" <wolfgang.rostek at gmx.de>, "Alexandre Montplaisir" <alexmonthy at voxpopuli.im>
>> Cc: lttng-dev at lists.lttng.org
>> Betreff: Re: Aw: Re:  Re: [lttng-dev] Can't get any event output from the demo exe [solved]
>> Alexandre, maintainer of the PPA packages, will be
>> back from vacation in 2 weeks.
>> Perhaps he could look into why you had to explicitly
>> uninstall packages before installing the PPA then.
>> Normally "conflicts with" should be taking care
>> of this kind of dependency.
>> Thanks,
>> Mathieu
>> ----- Original Message -----
>>> Just right before the weekend I could repair it.
>>> Seems that I had some trouble with the installed packages.
>>> Here the steps working for me on Ubuntu 14 LTS
>>> http://installion.co.uk/ubuntu/utopic/universe/l/lttng-tools/uninstall/index.html
>>> sudo apt-get remove --auto-remove lttng-tools
>>> https://launchpad.net/~lttng/+archive/ubuntu/ppa
>>> sudo apt-add-repository ppa:lttng/ppa
>>> sudo apt-get update
>>> sudo apt-get install lttng-tools lttng-modules-dkms babeltrace
>>> liblttng-ust-dev python3-babeltrace
>>> thanks for your investigations
>>> Wolfgang R.
>> -- 
>> Mathieu Desnoyers
>> EfficiOS Inc.
>> http://www.efficios.com

More information about the lttng-dev mailing list