[lttng-dev] Can't get any event output from the demo exe

Wolfgang Rostek wolfgang.rostek at gmx.de
Tue Mar 17 03:49:59 EDT 2015

Hi Jonathan,
as I'm struggling with the Internet style response I'll recap it here
> On session creation you can use -o to specify an output PATH.
Have tried to redirect to /tmp but no output there as well
> Did you build from source or you got binary from a package manager ?
yes, via git clone etc.
> What do you mean by talk to it?
I see daemon logs in response to the lttng commands. The exception is
that there is no reaction for the demo-trace run.
> Any particuliar reason to do an export LD_LIBRARY_PATH?
Ok, is no longer needed.
I've added the sleep but provider output is still like in my original post.
Below the steps I run again. Is it possible to get more info from the
demo-trace provider? Is the marked line ok?
Wolfgang R.
row at cobra7:~$ lsb_release -sd
Ubuntu 14.04.1 LTS

row at cobra7:~$ file /sbin/init
/sbin/init: ELF 32-bit LSB  shared object, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.24, BuildID[sha1]=c394677bccc720a3bb4f4c42a48e008ff33e39b1, stripped
=> 32bit

row at cobra7:~$ lttng-sessiond -vvv

row at cobra7:~/lttng_source/lttng-ust/doc/examples/demo$ export LTTNG_UST_DEBUG=1
row at cobra7:~/lttng_source/lttng-ust/doc/examples/demo$ lttng create
Session auto-20150317-075322 created.
Traces will be written in /home/local/ESG_GMBH/row/lttng-traces/auto-20150317-075322                       ####### not found
row at cobra7:~/lttng_source/lttng-ust/doc/examples/demo$ lttng enable-event -u -a
All UST events are enabled in channel channel0

row at cobra7:~$ ps -aux | grep ltt
root      4664  0.0  0.0  84416  3376 ?        Ssl  07:51   0:00 lttng-sessiond
row       4683  0.0  0.1  76220 13788 pts/1    Sl+  07:52   0:00 lttng-sessiond -vvv
row       4709  0.0  0.0  56096   672 pts/1    Sl+  07:53   0:00 lttng-consumerd --quiet -u --consumerd-cmd-sock /home/local/ESG_GMBH/row/.lttng/ustconsumerd32/command --consumerd-err-sock /home/local/ESG_GMBH/row/.lttng/ustconsumerd32/error --group tracing

row at cobra7:~/lttng_source/lttng-ust/doc/examples/demo$ lttng start
Tracing started for session auto-20150317-075322

row at cobra7:~/lttng_source/lttng-ust/doc/examples/demo$ ./demo-trace
liblttng_ust_tracepoint[5381/5381]: just registered a tracepoints section from 0xb7589780 and having 2 tracepoints (in tracepoint_register_lib() at tracepoint.c:767)
libust[5389/5390]: Info: sessiond not accepting connections to global apps socket (in ust_listener_thread() at lttng-ust-comm.c:1221)                #########  is this OK ?
libust[5389/5390]: Waiting for global apps sessiond (in wait_for_sessiond() at lttng-ust-comm.c:1132)
libust[5389/5391]: Info: sessiond not accepting connections to local apps socket (in ust_listener_thread() at lttng-ust-comm.c:1221)               #########  is this OK ?
libust[5389/5391]: Waiting for local apps sessiond (in wait_for_sessiond() at lttng-ust-comm.c:1132)
libust[5389/5389]: Provider "lttng_ust_tracef" accepted, version 1.0 is compatible with LTTng UST provider version 1.0. (in check_provider_version() at lttng-

row at cobra7:~$ lttng list  -u
UST events:

More information about the lttng-dev mailing list