[lttng-dev] Why is Python 2.7 required to build stock lttng-ust 2.4.0 ?

Amit Margalit AMITM at il.ibm.com
Tue Apr 1 09:51:04 EDT 2014


I've stumbled across this restriction, which seems quite arbitrary. I have 
an environment which is currently unable to update to Python 2.7, but I do 
want lttng-ust-2.4.0.

Looking into the code, it seems that if I don't cate about lttng-gen-tp, 
and the python bindings, then there is no reason to force this 

I went into configure.ac, and modified the 2.7 requirement like this:

$ diff -r lttng-ust-2.4.0/configure.ac lttng-ust-2.4.0-py26/configure.ac

Now, lttng-ust-2.4.0 builds cleanly with Python 2.6.

I'm sure someone can come up with a patch that will simply say "if all you 
have is 2.6, then lets use it, but set BUILD_GEN_TP_EXAMPLES=0, and if you 
have 2.7, then BUILD_GEN_TP_EXAMPLES=1".

Now my experience with autoconf is limited, otherwise I would have done 
this and submitted a patch.

Do you want me to open a ticket for this?

Amit Margalit
IBM XIV - Storage Reinvented
XIV-NAS Development Team
Tel. 03-689-7774
Fax. 03-689-7230
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lttng.org/pipermail/lttng-dev/attachments/20140401/716ef4f8/attachment.html>

More information about the lttng-dev mailing list