[lttng-dev] [PATCH lttng-modules] sched instrumentation: rename "pid" fields in sched_process_exec
Andrew Gabbasov
andrew_gabbasov at mentor.com
Sun Nov 25 14:39:14 EST 2012
Rename "pid" to "tid" fields in new code, similarly to what was
done earlier for all sched tracepoints.
Signed-off-by: Andrew Gabbasov <andrew_gabbasov at mentor.com>
---
instrumentation/events/lttng-module/sched.h | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/instrumentation/events/lttng-module/sched.h b/instrumentation/events/lttng-module/sched.h
index ca46ed0..005f3d1 100644
--- a/instrumentation/events/lttng-module/sched.h
+++ b/instrumentation/events/lttng-module/sched.h
@@ -326,18 +326,18 @@ TRACE_EVENT(sched_process_exec,
TP_STRUCT__entry(
__string( filename, bprm->filename )
- __field( pid_t, pid )
- __field( pid_t, old_pid )
+ __field( pid_t, tid )
+ __field( pid_t, old_tid )
),
TP_fast_assign(
tp_strcpy(filename, bprm->filename)
- tp_assign(pid, p->pid)
- tp_assign(old_pid, old_pid)
+ tp_assign(tid, p->pid)
+ tp_assign(old_tid, old_pid)
),
- TP_printk("filename=%s pid=%d old_pid=%d", __get_str(filename),
- __entry->pid, __entry->old_pid)
+ TP_printk("filename=%s tid=%d old_tid=%d", __get_str(filename),
+ __entry->tid, __entry->old_tid)
)
#endif
--
1.7.10.4
More information about the lttng-dev
mailing list