[ltt-dev] Kernel Oops during lttctl_start()

Bernd Hufmann Bernd.Hufmann at ericsson.com
Mon Apr 18 10:04:54 EDT 2011


I was using the LTTng agent to control LTTng Kernel tracing. Everything 
worked fine until I tried to disable certain channels (command 
setChannelEnable()). Interestingly, this command doesn't fail, however 
the sub-subsequent command startTrace() fails. I did some debugging of 
the LTTng agent to investigate the problem. I'm able to pin-point the 
last line of execution, which is in the library liblttctrl. There is a 
crash and the tcf-agent becomes a zombie process (defunc). When I 
display kernel messages with the shell command dmesg I see a kernel 
oops. After the error occurred, the remote machine has to be rebooted. 
I'm not able to debug further and need some support.

Could someone please look into the problem? Please let me know if you 
have any questions.

Steps to reproduce:
     - Enable all markers (use ltt-armall)
     - Start tcf-client
     - connect <remote>
     - tcf ltt_control setupTrace "kernel" "0" "h2"
     - tcf ltt_control setChannelEnable "kernel" "0" "h2" false
     - tcf ltt_control allocTrace "kernel" "0" "h2"
     - lttctl_client ltt_control writeTraceLocal "kernel" "0" "h2" 
"/tmp/h2" 2 false false false
     - tcf ltt_control startTrace "kernel" "0" "h2"

Now, the command startTrace won't return. It hangs on line "if 
(write(fd, op, strlen(op)) == -1)" of method "lttctl_sendop()" which was 
called by method "lttctl_start()" (see file liblttctrl.c). Please see 
attached file "dmesg_start.log" for the dmesg output.

My target node (running in virtualbox) has the following versions installed:

- Ubuntu 10.10
- Instrumented kernel 2.6.35-24 installed from the PPA repository at 
- manually upgraded UST 0.12
- manually upgraded lttng-agent from the git repository 
(git.dorsal.polymtl.ca/git/lttng-agent.git), master branch of 23 March 2011

Thank you very much in advance!

Best Regards
-------------- next part --------------
A non-text attachment was scrubbed...
Name: dmesg_start.log
Type: text/x-log
Size: 31472 bytes
Desc: not available
URL: <http://lists.casi.polymtl.ca/pipermail/lttng-dev/attachments/20110418/8cacd41f/attachment-0003.bin>

More information about the lttng-dev mailing list