[ltt-dev] [RFC] UST Tracepoint API Changes
compudj at krystal.dyndns.org
Sat Nov 5 08:16:11 EDT 2011
* Matthew Khouzam (matthew.khouzam at ericsson.com) wrote:
> On 11-11-02 10:00 AM, Mathieu Desnoyers wrote:
> > 2) Not sure about the following one: TRACEPOINT_EVENT is quite long to
> > type in, and so it "tracepoint()", and the upcoming
> > "tracepoint_printf()". I'm thinking about going for shorter names, but I
> > also want to try not to get conflicts with existing code out there.
> > Ideas on a shorter yet explanatory name would be very welcome.
> > tp_* seems a little bit short and prone to conflicts.
> sounds like toilet paper, and it is used a lot with other projects.
> > tracep_ sounds too much like ptrace.
> also, the p is ambiguous, why not just trace_ at that point?
> > tracept_ might be good enough. It's only downside might be to sound like
> > "trace-pity" when we say it out loud. ;-)
> pt is the unsaid shorthand for point. it would be easily understood by
> most IMO. but at this point you are three letters away from tracepoint_
> I would suggest going full length and letting those who don't like
> typing either the option to use a code completing IDE like eclipse-cdt,
> or making macros that make sense to them.
I'm thinking that we could keep:
TRACEPOINT_EVENT()/tracepoint() for the production-style
instrumentation. It is meant to be well-thought anyway, so it does not
hurt if it takes a bit more time to type in.
For debug-style instrumentation, trace_printf() looks really
interesting, and I don't find matches with google (the first matches are
trace_printk(), in the kernel).
> > Thanks,
> > Mathieu
> ltt-dev mailing list
> ltt-dev at lists.casi.polymtl.ca
Operating System Efficiency R&D Consultant
More information about the lttng-dev